User Tools

Site Tools


upgrade_freezy

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
upgrade_freezy [2019/04/29 10:57]
pinupadmin
upgrade_freezy [2019/10/18 19:02] (current)
A User Not Logged in
Line 32: Line 32:
  
 [[https://​github.com/​freezy/​dmd-extensions/​releases|https://​github.com/​freezy/​dmd-extensions/​releases]] [[https://​github.com/​freezy/​dmd-extensions/​releases|https://​github.com/​freezy/​dmd-extensions/​releases]]
 +
 +Note:  as of this day you should use 1.7.1 as 1.7.2 has bugs in dmdext that won't support color roms.
  
 PLEASE READ AND MAKE THE REQUIRED CHANGES! PLEASE READ AND MAKE THE REQUIRED CHANGES!
  
-First: install the new Freezy dmdext 1.7 files (32 bit ONLY!!!) into your VPinMAME folder. Make sure you delete, or copy over any other versions of dmddevice.dll that you have elsewhere on your system! Also, if you have a file called Libdmd.DLL in your VPinMAME, you need to delete that file, or dmdext will crash!+First: install the new Freezy dmdext 1.7 files (x86- 32 bit ONLY!!!) into your VPinMAME folder. Make sure you delete, or copy over any other versions of dmddevice.dll that you have elsewhere on your system! Also, if you have a file called Libdmd.DLL in your VPinMAME, you need to delete that file, or dmdext will crash!
  
 Two important changes that needs to be done with Popper and PuP for everyone who upgrades…. Two important changes that needs to be done with Popper and PuP for everyone who upgrades….
Line 43: Line 45:
 **For VPX, you need to change the dmddevice.ini** **For VPX, you need to change the dmddevice.ini**
  
-The [video] section should now be disabled (it was enabled for PinUP before). It should look like this: +The [video] section should now be disabled (it was enabled for PinUP before). It should look like this:<​code>​
- +
-<​code>​+
 [video] [video]
 ; if enabled, writes frames to an .avi file ; if enabled, writes frames to an .avi file
Line 89: Line 89:
  
 ====== ​  ​====== ====== ​  ​======
- 
-**For FX3**, you need to change the PuP portion of the command line for launching in Popper and PBX! It used to be: 
-<​code>​ 
--o PINUP\[GAMENAME] (this was 1.6) 
-</​code>​ 
- 
-It is now is replaced with: 
- 
-<​code>​ 
---pinup PINUP\[GAMENAME] 
-</​code>​ 
- 
-An example for Popper launch script is (with version 1.71 of dmdext, using the legacy method for FX3): 
- 
-<​code>​ 
-start /min ""​ "​dmdext.exe"​ mirror --source=pinballfx3 --fx3-legacy -q -d auto --virtual-hide-grip --virtual-position=3400 5 400 --pinup PINUP\[GAMENAME] 
-</​code>​ 
- 
-====== ​  ​====== 
- 
-Another big plus for VPX PuP-Packs! You can now choose any colour (or coloured) DMD you want! You no longer need to set a specific colour for the DMD thanks to DJRobX'​s wizardry! 
- 
-Reminder: Your FX3 must be setup properly work with dmdext (not a Popper thing). You need to make sure your dmd is set to 1040 x 272 if using legacy mode. See full instructions here: [[https://​github.com/​freezy/​dmd-extensions|https://​github.com/​freezy/​dmd-extensions]] 
- 
-====== ​  ​====== 
- 
-A BIG thanks to Freezy, Lucky, and DJRobX for putting in the work to bring this miracle to the community! 
  
  
upgrade_freezy.txt · Last modified: 2019/10/18 19:02 by A User Not Logged in